Overview
Let’s take a look at what needs to be done to get your Cisco 9200/9300 switch ready for the installation of your WheatNet‑IP system. Properly configuring your switch allows you to take advantage of the “management” capabilities to control network traffic and allows the network to operate at its highest potential. This becomes necessary to prevent overloading the network as the system size increases.
In this setup process you will setup switch ports according to the type of device connecting to that port. You will be setting things like VLAN access, Trunking, Speed, etc. Each section below gives you the exact commands needed to get your WheatNet‑IP network up running.
Below is a chart that gives you some information about the commands you will be using to complete the setup. This can be a quick reference for you as well:
Command | Purpose |
Configure Terminal
| Enter Global configuration mode on switch
|
Interface
| Enter interface configuration mode
|
Switchport mode access
| Configures the port as an access port
|
Switchport mode Trunk
| Configures port for trunking to other switches
|
Switchport nonegotiate
| Prevents DTP frames from being generated
|
Spanning-tree portfast
| Enables portfast on the switch port
|
Show running-config
| Show the current running configuration
|
Write memory
| Writes the configuration to memory on the switch
|
IP igmp snooping querier
| Enables IGMP querier
|
IP igmp snooping querier timer expiry
| Set the length of time until the IGMP querier expires
|
This document will explain the initial configuration of the Cisco 9200/9300/C1000 series switch. To get started you will need the blue console cable that came with your switch. Go ahead and connect the console cable to the serial port on your PC and the RJ‑45 to the console port on the switch. If your PC is not equipped with a serial port you will need a USB to Serial converter. There are also console cables with a built-in serial port available from retailers like MicroCenter and Amazon.
If you do not have the blue Cisco console cable there is an alternative. Cisco is now shipping with a USB console port on most of the new models. You can download the USB driver needed from the Cisco download site. You will need to download the Cisco_usbconsole_driver.
Next let’s get your PC ready to communicate. You will need a terminal program such as PuTTY to finish this portion of the setup. PuTTY is an application you can use in order to connect your computer to other remote systems. These systems include other switches, routers, other computers, and Telnet sites.
To get started, open PuTTY and start a new connection. The terminal session should be setup using 9600Baud, 8 bit, no Parity, and no Flow control.
For those who are familiar with the Cisco IOS you may wish to jump ahead to the commands. For the rest, keep reading and we’ll walk you through it step by step.
Along the way we’ll even explain why we use the commands below so that you have some basic understanding of what you are doing. Hopefully you will walk away with some new found knowledge.
Privileged EXEC Mode
Now that we are connected to the switch let’s log in. When logging into a Cisco switch under the default configuration, you are in user EXEC mode (level 1). In EXEC mode, you have limited access to the status of the switch. However, you can’t make any changes or view the running configuration file.
Because of these limitations, you need to type enable to get out of user EXEC mode. By default, typing enable takes you to “Privileged” EXEC mode (Level 15). In the Cisco IOS, this level is equivalent to having root privileges in UNIX or administrator privileges in Windows. In other words, you have full access to the switch.
Let’s get started on the configuration of your switch. Type “enable” command at the prompt. When prompted, enter the password and press Enter again. If no password has been defined just press Enter.
NOTE: The command prompt now ends with “#” indicating you are now at the Privileged EXEC mode (Level 15).
Global Configuration Mode
To enter the IP address and Subnet Mask for the VLAN or configure the switch ports you must first enter the configuration mode. To enter the global configuration mode on the switch type “Config T” and press Enter. This places the switch in Global configuration mode and will allow configuration from the terminal window for the selected interface. You should now have the switch (config)# prompt.
"config t" is a shortcut for configure terminal, so if that's the command you learned to use in the past, it's the same thing.
Configuring the VLAN Interface
A VLAN is a switched logical network that is segmented based on the function or application. VLANs are virtual LANs but have the same attributes as the physical LAN. VLANs allow a user to create a virtual broadcast domain in which traffic can be isolated to keep it from reaching unwanted destinations. Any switch port can belong to a VLAN, and unicast, broadcast, and multicast packets are forwarded only to those end stations assigned to that VLAN.
Now that you are in the Global configuration mode you need to select the interface that you would like to configure. We’ll start with the default VLAN.
The switch will come with a default VLAN enabled. In the default configuration all ports on the switch have been assigned to VLAN1. The command below selects the default VLAN for configuration to segment network traffic on the switch. If you are adding an additional VLAN to existing hardware, substitute that VLAN number in place of 1.
Enter the following commands (“XXX” = the actual network IP address):
interface Vlan1
ip address 192.168.87.XXX 255.255.255.0
end
Let’s look at what you just set up. By typing “interface Vlan1” you are entering the configuration for that VLAN. The “IP Address” command simply sets the IP address of the VLAN1 interface for remote management purposes. The IP address must be unique on the network.
Tip: Set the core switch of the system to the lowest IP address. When the switches elect an IGMP Snooping Querier, they will select the switch with the lowest IP address, so you want the largest switch in the system to have the lowest IP address.
IGMP Snooping Querier Configuration
To set up IGMP Snooping Querier on the switch you must be in the Global configuration mode. To enter the configuration mode once again type “Config T” and press Enter.
Enter the following commands:
ip igmp snooping querier
ip igmp snooping
querier max-response-time 25 ip igmp snooping querier timer expiry 205
end
By default IGMP Snooping is globally enabled on the switch. It is enabled on VLANs by default. Global IGMP snooping takes precedent over VLAN IGMP Snooping. If globally disabled you cannot enable IGMP Snooping on a per VLAN basis.
The commands above simply enable the querier on the switch and set a few values for maximum response time and the expiration duration for the querier.
Configuring Access Ports
In WheatNet-IP, every blade and surface will connect to an Access Port on the Cisco Switch. This includes:
- Blade 3
- Blade 4
- Consoles
- Talent Stations
- WNIP PC Drivers
- The switch built into the Audioarts DMX Blade
- XY Controllers
Configuring the ports on the Cisco 9200/9300/C1000 series switch is a key step in ensuring op‑timal performance of the Wheatnet‑IP network. This section will guide you in the setup of each port used for WheatNet‑IP I/O BLADE 3s or BLADE4s.
Switch ports operate in one of three modes, dynamic, trunk, or access mode.
Switch ports connecting to Wheatstone IP devices must be in Access mode. Access mode places the port in static access mode and gives it access to the default VLAN. The switchport nonegotiate command disables the Dynamic Trunking Protocol and tells the port not to generate DTP frames.
To setup ports on the switch you must also be in the Global Configuration mode. To enter the configuration mode once again type “Config T” and press Enter.
Enter the following commands based on the OS versions of your switch:
• OS any version prior to version 15.0
interface Gi1/0/x (x=the Ethernet port
being configured)
switchport mode
access
switchport nonegotiate
switchport block multicast
no ip igmp snooping tcn flood
spanning-tree
portfast
end
• OS any version after 15.0
interface Gi1/0/x (x=the Ethernet port
being configured)
switchport mode access
switchport nonegotiate
no ip igmp snooping tcn flood
spanning-tree portfast
end
Ports on the switch can be configured
individually or in a “Range.” If range is desired type Interface range Gi0/1-24 using the desired number of ports instead of the single interface command. If you get a syntax error on the interface or interface range command, it could be that the ports are numbered differently than our example. This happens on stacked switches. Do a show running-config to see how the switch has named its ports so you can match it.
Configuring Trunk Ports
A Trunk Port is one that connects this switch to another Cisco switch. (Or another manufacturer's switch that follows IGMP standards)
To set a specified port to trunk mode when connecting to another managed network switch the port needs to be set for Trunk mode.
To setup Gigabit ports on the switch you must also be in the Global Configuration mode. To enter the configuration mode once again type “Config T” and press Enter.
Enter the following commands based on the OS versions of your switch:
• OS any version prior to version 15.0
Interface Gi1/0/x (x=the Ethernet port
being configured)
switchport mode
trunk
switchport nonegotiate
switchport block multicast
no ip igmp snooping tcn flood
end
• OS any version after 15.0
interface Gi1/0/x (x=the Ethernet port
being configured)
switchport mode
trunk
switchport nonegotiate
no ip igmp snooping tcn flood
end
Checking And Saving Your Switch Configuration
When you are done, check the switch configuration by typing the following command from the command prompt:
show running-config
Once you are sure you have the correct configuration you need to save it. You can save the configuration by typing one of the following commands:
copy running-config startup-config
or
write memory
If you don't save your work, everything you just did will be lost the next time that the switch is power cycled or rebooted.